Author Topic: Can not repeat the result of piezoelectric coefficients of example GaAs  (Read 891 times)

0 Members and 1 Guest are viewing this topic.

Offline arlonne

  • New ATK user
  • *
  • Posts: 9
  • Country: cn
  • Reputation: 0
    • View Profile
Dear all,

 I am attempting to repeat the result of the example  of piezo_GaAs.py (in Page 723 of Reference-Manual, Release 2017.2). Below is my result with 2017.2 version QATK:
"
+------------------------------------------------------------------------------+
| Piezoelectric Tensor Report                                                  |
+------------------------------------------------------------------------------+
|                                                                              |
| Tensor in units of [C/m**2]:                                                 |
|                                                                              |
|           x              y              z                                    |
| xx    4.05800e-01    9.68754e-01    1.02461e+00                              |
| yy    1.67280e-01   -2.57980e+00    1.91885e+00                              |
| zz    1.46679e+00    1.32262e-01    5.77928e-01                              |
| yz   -1.71568e+00    9.27315e-03    9.77441e-03                              |
| xz    9.27315e-03   -9.92013e-01    9.27315e-03                              |
| xy    9.77441e-03    9.27315e-03   -1.43153e+00                              |
|                                                                              |
+------------------------------------------------------------------------------+
"
And this is the result in Page 273:
"
+------------------------------------------------------------------------------+
| Piezoelectric Tensor Report |
+------------------------------------------------------------------------------+
| |
| Tensor in units of [C/m**2]: |
| |
| x y z |
| xx 2.01774e-12    1.27223e-12    1.18732e-12 |
| yy 2.86045e-13   7.92764e-13   5.13819e-13 |
| zz 9.78384e-13   4.45648e-13  -2.59427e-13 |
| yz -8.28198e-01  1.48791e-13  -9.55916e-14 |
| xz 1.17508e-13     -8.28198e-01   7.05227e-14 |
| xy 1.28983e-13      3.64354e-14   -8.28198e-01 |
| |
+------------------------------------------------------------------------------+
"
You can see that they are totally different!!! So, what's wrong?
I appreciate your help! Thanks.

Offline Nordland

  • QuantumATK Staff
  • Supreme ATK Wizard
  • *****
  • Posts: 812
  • Reputation: 18
    • View Profile
Are you running the exact same script from the manual?

Offline F. Fuchs

  • Regular ATK user
  • **
  • Posts: 18
  • Country: de
  • Reputation: 0
    • View Profile
I just tried to reproduce the piezoelectric tensor from the manual (https://docs.quantumatk.com/manual/Types/PiezoelectricTensor/PiezoelectricTensor.html) as well. I am using version Q-2019.12. The result I got also disagrees with the manual. There is also different to what arlonne has posted earlier.
And yes, I just copied and pasted the input script from the manual.

Maybe some defaults have been changed from version to version? An update of the manual would be nice in this case.

The result I got is also wrong in the sense that the xx, yy, zz components are not zero. Thus, I suppose that the input script in the manual requires more precise DFT parameters.

Regards,
Florian


Result with Q-2019.12 using the input file from https://docs.quantumatk.com/manual/Types/PiezoelectricTensor/PiezoelectricTensor.html
+------------------------------------------------------------------------------+
| Piezoelectric Tensor Report                                                  |
+------------------------------------------------------------------------------+
|                                                                              |
| Tensor in units of [C/m**2]:                                                 |
|                                                                              |
|           x              y              z                                    |
| xx    7.44784e-01    9.67739e-01   -7.44377e-02                              |
| yy   -7.44414e-02    1.83366e-01   -7.44846e-02                              |
| zz   -7.44414e-02    9.67739e-01   -8.62789e-02                              |
| yz   -1.87937e+00   -7.51877e-04   -2.50626e-04                              |
| xz   -7.51875e-04   -1.33056e+00   -7.51877e-04                              |
| xy    9.77514e-03    9.26680e-03    2.69444e+00                              |
|                                                                              |
+------------------------------------------------------------------------------+
« Last Edit: November 20, 2020, 09:46 by F. Fuchs »

Offline Troels-Markussen

  • Regular ATK user
  • **
  • Posts: 35
  • Country: dk
  • Reputation: 1
  • QuantumATK staff
    • View Profile
Hi Florian, I have attached a modified script, which I believe works correctly. Indeed the documentation has not been updated along with changed defaults and it also doesn't reflect the defaults in PiezoElectricTensor calculation. For calculations involving the Berry phase Polarization (i.e. Polarization, BornEffectiveCharges, and PiezoElectricTensor) it is often necessary to decrease the electronic temperature from the default of 1000 K. For the PiezoElectricTensor calculation itself, notice that we can calculate either the clamped ion contribution or the full contribution. The former is calculated by setting
Code
optimize_geometry=False
while the later is obtained with
Code
optimize_geometry=True
Both calculations are performed in the attached script. Regards, Troels