Author Topic: Band, dos and pdos doesn't match  (Read 149 times)

0 Members and 1 Guest are viewing this topic.

Offline dprai

  • Regular ATK user
  • **
  • Posts: 16
  • Country: in
  • Reputation: 0
  • Learning Simulation of Nanoelectronics
    • View Profile
Band, dos and pdos doesn't match
« on: May 11, 2022, 09:38 »
Dear experts,

I am currently working on nanoribbons and faced some difficulty in understanding the mismatch in the band and the pdos plots. I have used a very dense k-point(1x1x100) for the calculations and the structures are also well converged(0.01ev/angs). For the pristine system the pdos, dos, and band-structure match well but when I run the calculations fr the doped system, the contribution from the doped element's orbital is missing from the pdos. I have run the calculation using Semi-empirical, DFT-LCAO with different functional too, but the error still persists. If anyone from the forum can assist me in resolving the problem would be highly appreciated. I have attached the file.

The 3-band lines observed between 2 and -1.7 are contributed by the dopant and the same is missing from the PDOS as well as the DOS(i haven't attached the dos here).

Offline dprai

  • Regular ATK user
  • **
  • Posts: 16
  • Country: in
  • Reputation: 0
  • Learning Simulation of Nanoelectronics
    • View Profile
Re: Band, dos and pdos doesn't match
« Reply #1 on: May 13, 2022, 06:46 »
Any suggestions?
I cannot share my python scripts directly here at the forum as it is my ongoing work.

Offline AsifShah

  • Regular ATK user
  • **
  • Posts: 23
  • Country: in
  • Reputation: 0
    • View Profile
Re: Band, dos and pdos doesn't match
« Reply #2 on: May 16, 2022, 10:58 »
Can you kindly plot DOS, PDOS seperately along with Legend for orbitals in PDOS?